Posts Tagged ‘ VPN ’

Cisco VPN, Windows 7, WWAN and artificial restrictions.

So I have a fleet of laptops with WWAN cards built in. I also have an ASA5510 that terminates my VPN.
I was having this issue when using VPN over the WWAN all the traffic was getting Bypassed or Discarded. It made no sense as they were connecting correctly and everything else was fine. A quick read of the release notes for Cisco VPN revealed that they “don’t support” VPN over WWAN on Windows 7 unless you use AnyConnect.
To me, this stunk like the “we don’t support VPN Client on x64” nonsense. So some more reading later and I found they do support one PPP connection and my WWAN adaptor exposes a Modem device. Here is the details of how to make it work, so you too can dodge this rubbish:

Firstly you need to change the configuration of the Modem device in device manager. In the advanced tab of the modem device for you WWAN adaptor add the following to your “Extra initialization commands” :  at+cgdcont=1,”IP”,”<INSERT APN HERE>”

Once you have that done you need to create a Dial-up connection using your WWAN adaptors modem device with the following settings (well these ones work in Australia)

Dialup number: *99***1#
User & Password: <blank>
Allow other people: Yes (optional but recomended)

Then hit connect, it should connect and be happy, then click close.

Once this is done you can change the settings to be less annoying.
View the properties of the connection and go to the options tab.
In here Un-tick Prompt for name and prompt for phone number.
Some OK clicking will follow

Then you should be good to go. I usually disable the “Mobile Broadband Connection” in Network Connections to prevent and confusion.